aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Stewart <bst@google.com>2016-05-25 14:36:51 -0700
committerAnders Broman <a.broman58@gmail.com>2016-08-15 07:13:35 +0000
commit0ebaffe0a8b319a2a9b1072d01214834286dff05 (patch)
tree1bc286fd0666a41a2e6bf0afde4f5e0bac2d9292 /epan/dissectors/CMakeLists.txt
parenta5166affc47a9954c5177994c9b83f34313c7eb4 (diff)
Implement support for SCTE-35 switching messages.
This module implements a dissector for the main table in a SCTE-35 message, a splice_info_section. This payload is carried in a MPEG Section Table with a table ID of 0xFC. PIDs carrying this sort of table are also noted in the PMT with a stream type of 0x86, and a registration descriptor with fourcc 'CUEI'. The various splice command types are implemented in separate modules, and are linked to this dissector through the field scte35.splice_command_type. Field names follow the conventions documented in the SCTE35 specification. This dissector does not support encrypted SCTE35 messages, other than indication through the scte35.encrypted_packet flag. The SCTE-35 protocol is described by the Society of Cable Telecommunications Engineers at <https://www.scte.org/documents/pdf/Standards/Top%20Ten/ANSI_SCTE%2035%202013.pdf>. Bug: 12521 Change-Id: I3113e6e61a4e7f1a4a932a0128ca2846c7ce6e6f Reviewed-on: https://code.wireshark.org/review/15562 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index 0d16b3777e..f09bf68a94 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -1161,6 +1161,7 @@ set(DISSECTOR_SRC
packet-scsi-smc.c
packet-scsi-ssc.c
packet-scsi.c
+ packet-scte35.c
packet-sctp.c
packet-sdh.c
packet-sdlc.c