aboutsummaryrefslogtreecommitdiffstats
path: root/epan/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2001-07-26 07:25:49 +0000
committerGuy Harris <guy@alum.mit.edu>2001-07-26 07:25:49 +0000
commitae251f8426ca1100481de82d652ad0bf11c41e22 (patch)
treea67815389a48d6d2a6dd802008cdfa809d14a7c9 /epan/configure.in
parentd299f1e4ed8427801562bf3677aa0e3a3c284dc1 (diff)
MacOS support changes, from Michael Tuexen (with some modifications):
replace "--with-plugindir" with "--with-plugins", and have the plugin directory optional - this allows plugins to be disabled; add "--traditional-cpp" on MacOS X/Darwin (Apple's "cc" compiler requires it, for some annoying reason, even though it is, as far as I know, GCC-based, and other GCC's don't require it); on MacOS X, don't use "pcap_version[]", as, for some annoying reason, libpcap on MacOS X doesn't define it. Clean up some whitespace in the help messages for the configure script. Move the AM_CONDITIONAL for SETUID_INSTALL after the point at which "enable_setuid_install" is set, as it tests "enable_setuid_install". svn path=/trunk/; revision=3788
Diffstat (limited to 'epan/configure.in')
-rw-r--r--epan/configure.in41
1 files changed, 39 insertions, 2 deletions
diff --git a/epan/configure.in b/epan/configure.in
index e9bce6b40f..5d9382318d 100644
--- a/epan/configure.in
+++ b/epan/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.11 2001/07/13 13:54:56 jfoster Exp $
+# $Id: configure.in,v 1.12 2001/07/26 07:25:46 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -16,6 +16,9 @@ AC_PREREQ(2.13)
AM_INIT_AUTOMAKE(libethereal.a, 0.8.19)
AM_CONFIG_HEADER(config.h)
+dnl Check for CPU / vendor / OS
+AC_CANONICAL_HOST
+
dnl Checks for programs.
AC_PROG_CC
AC_PROG_CPP
@@ -59,7 +62,15 @@ then
;;
esac
else
+ case "$host_os" in
+ darwin*)
+ CFLAGS="-traditional-cpp $CFLAGS"
+ AC_MSG_RESULT(Apple cc compiler - added -traditional-cpp)
+ ;;
+ *)
AC_MSG_RESULT(none needed)
+ ;;
+ esac
fi
# Create DATAFILE_DIR #define for config.h
@@ -174,9 +185,35 @@ main ()
#LIBS="$ac_save_LIBS"
if test "$ac_cv_glib_supports_modules" = yes ; then
AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_PLUGINS)
+ have_plugins=yes
else
AC_MSG_RESULT(no)
+ have_plugins=no
+fi
+
+dnl
+dnl check whether plugins should be enabled; we don't set PLUGIN_DIR,
+dnl as that's set by the top-level configure script
+dnl
+AC_ARG_WITH(plugins,
+ [ --with-plugins=DIR support plugins (installed in DIR, if supplied)],
+ [
+ case "$withval" in
+ "" | y | ye | yes )
+ ;;
+ n | no)
+ have_plugins=no
+ ;;
+ *)
+ ;;
+ esac
+ ]
+)
+
+AM_CONDITIONAL(HAVE_PLUGINS, test x$have_plugins = xyes)
+if test x$have_plugins = xyes
+then
+ AC_DEFINE(HAVE_PLUGINS)
fi
AC_OUTPUT(