aboutsummaryrefslogtreecommitdiffstats
path: root/epan/configure.in
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2003-12-06 16:35:20 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2003-12-06 16:35:20 +0000
commit55a6251e7c52b3610cd8992b541be919a5dca5aa (patch)
tree11537545c74d4f5276cfffaf8cb7b2ad4e6fbba8 /epan/configure.in
parent71c8b6077b28245ed7f65e129bf0bcab1066947e (diff)
From Olivier Biot
New "matches" operater in display filter language. Uses PCRE. If a "matches" operator is found in a dfilter while libpcre has not been used to build the binary, then an exception is thrown after using dfilter_fail() to set an apporporiate error message. svn path=/trunk/; revision=9182
Diffstat (limited to 'epan/configure.in')
-rw-r--r--epan/configure.in36
1 files changed, 35 insertions, 1 deletions
diff --git a/epan/configure.in b/epan/configure.in
index f540653059..a6501d3c51 100644
--- a/epan/configure.in
+++ b/epan/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.49 2003/11/18 08:13:09 guy Exp $
+# $Id: configure.in,v 1.50 2003/12/06 16:35:18 gram Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -235,6 +235,40 @@ AC_CHECK_FUNC(strptime, ,
[AC_DEFINE(NEED_STRPTIME_H, 1, [Define if strptime.h needs to be included])
])
+dnl pcre check
+AC_MSG_CHECKING(whether to use libpcre for regular expressions in dfilters)
+AC_ARG_WITH(pcre,
+changequote(<<, >>)dnl
+<< --with-pcre[=DIR] use libpcre (located in directory DIR, if supplied) to use in dfilter regular expressions. [default=yes, if present]>>,
+changequote([, ])dnl
+[
+ if test $withval = no
+ then
+ want_pcre=no
+ elif test $withval = yes
+ then
+ want_pcre=yes
+ else
+ want_pcre=yes
+ pcre_dir=$withval
+ fi
+],[
+ #
+ # Use libpcre if it's present, otherwise don't.
+ #
+ want_pcre=ifpresent
+ pcre_dir=
+])
+if test "x$want_pcre" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_ETHEREAL_LIBPCRE_CHECK
+ if test "x$want_pcre" = "xno" ; then
+ AC_MSG_RESULT(libpcre not found - disabling support for perl compatible regular expressions in dfilters)
+ fi
+fi
+
dnl ADNS Check
AC_MSG_CHECKING(whether to use the GNU ADNS library if available)
if test "x$enable_adns" = "xno" ; then