aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-03 00:42:00 +0100
committerJoão Valverde <j@v6e.pt>2017-09-15 10:11:55 +0000
commite7ef19efc0e928b50644b37772ccbf176e74f766 (patch)
tree1d6a4bb5163e5b094d5c5879d96b961113258315 /epan/Makefile.am
parentc52a702ae81b1ae7311a8b58e625f86fb211e7c5 (diff)
autotools: Initial work to install headers for the benefit of plugins
Install public headers required to build plugins for libwireshark (taps and dissectors). The source tree is organized to serve the CLI/GUI parts of wireshark. Plugins are built in tree. This change is intende to allow plugins to be built out-of-tree but we want to avoid dumping all headers into /usr/include. To be continued incrementally to fix errors and omissions. Change-Id: Iaa0def0ba3de4b456a29114c315544d2d64fa748 Reviewed-on: https://code.wireshark.org/review/23374 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 575e922b67..b1c4afb693 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -170,7 +170,7 @@ LIBWIRESHARK_ALL_SRC = \
$(LIBWIRESHARK_SRC) \
$(LIBWIRESHARK_GENERATED_SRC)
-LIBWIRESHARK_INCLUDES = \
+LIBWIRESHARK_INCLUDES_PUBLIC = \
addr_and_mask.h \
addr_resolv.h \
address.h \
@@ -210,7 +210,6 @@ LIBWIRESHARK_INCLUDES = \
dwarf.h \
eap.h \
eapol_keydes_types.h \
- epan-int.h \
epan.h \
epan_dissect.h \
etypes.h \
@@ -282,7 +281,6 @@ LIBWIRESHARK_INCLUDES = \
tfs.h \
time_fmt.h \
to_str.h \
- to_str-int.h \
tvbparse.h \
tvbuff.h \
tvbuff-int.h \
@@ -293,13 +291,21 @@ LIBWIRESHARK_INCLUDES = \
x264_prt_id.h \
xdlc.h
+LIBWIRESHARK_INCLUDES_PRIVATE = \
+ epan-int.h \
+ to_str-int.h
+
+subpkgincludedir = $(pkgincludedir)/epan
+
+subpkginclude_HEADERS = $(LIBWIRESHARK_INCLUDES_PUBLIC)
+
#Since code generated by lex may trigger gcc warnings, we are now generating two
#libraries. A single library is generated with the lex code without the barrier
#"stop on warning". An other library is generated from the remaining source
#files with the "stop on warning" barrier.
libwireshark_la_SOURCES = \
$(LIBWIRESHARK_SRC) \
- $(LIBWIRESHARK_INCLUDES) \
+ $(LIBWIRESHARK_INCLUDES_PRIVATE) \
ws_version_info.c
libwireshark_la_CPPFLAGS = $(AM_CPPFLAGS) -DWS_BUILD_DLL