aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2012-02-28 09:00:05 +0000
committerGuy Harris <guy@alum.mit.edu>2012-02-28 09:00:05 +0000
commitb252f2e632f224e41772bda8749168490d198461 (patch)
treec9975b8fc54a9bf1334163b4eec76f2477a67ca3 /epan/Makefile.am
parentc503c241c0dcbe3b30bee99dedd0873aa156d9e8 (diff)
OK, to heck with it - link reassemble_test with libwireshark. Trying to
selectively pick up particular object files is just too much of a mess. Alas, this requires that we add some additional symbols to the list exported by libwireshark; the DCE RPC ones shouldn't be global, but reassemble_test uses them, so.... Get rid of stubs in reassemble_test.c - they just stub out routines from libwireshark, but that's not necessary any more. svn path=/trunk/; revision=41223
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index ccbd6e700c..af858a483f 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -1,6 +1,7 @@
# Makefile.am
-# Automake file for the EPAN library
-# (Ethereal Protocol ANalyzer Library)
+# Automake file for the libwireshark library
+# (EPAN is a historical name; it stands for Ethereal Protocol ANalyzer
+# Library)
#
# $Id$
#
@@ -150,12 +151,11 @@ libwireshark_la_DEPENDENCIES = \
${top_builddir}/wiretap/libwiretap.la \
libwireshark.sym
-#EXTRA_PROGRAMS = reassemble_test
-#reassemble_test_LDADD = $(GLIB_LIBS)
-
-reassemble_test: reassemble_test.o packet.o tvbuff.o except.o to_str.o strutil.o emem.o \
- reassemble.o charsets.o
- $(LINK) $^ $(GLIB_LIBS) -lz
+EXTRA_PROGRAMS = reassemble_test
+reassemble_test_LDADD = \
+ libwireshark.la \
+ $(GLIB_LIBS) \
+ -lz
tvbtest: tvbtest.o tvbuff.o except.o to_str.o strutil.o emem.o charsets.o
$(LINK) $^ $(GLIB_LIBS) -lz