aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorAnders Broman <anders.broman@ericsson.com>2011-10-16 17:24:50 +0000
committerAnders Broman <anders.broman@ericsson.com>2011-10-16 17:24:50 +0000
commit22d5e8a8d13958be5851b7d987fb611de178d84f (patch)
tree8e47f84a7c4ce772c09d508e0cc867fb7efeaf6e /epan/Makefile.am
parent44eb67d3c7cb75a9bb6cecb6bdd4ec5d6ce897eb (diff)
From Eliot:
This patch adds the symbols to a filter expression, and should remove them if you are building without python. https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=6448 svn path=/trunk/; revision=39439
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index d624c49c01..edcf1a1722 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -195,6 +195,14 @@ if !HAVE_PLUGINS
def_sym_filter_symbols += /^register_all_wiretap_modules/ || /^register_all_plugin_tap_listeners/ || /^plugin_list/ {next;};
endif
+if HAVE_LIBPY
+# If we're not building python, these symbols don't get built.
+# Keep them out of the symbol list.
+def_sym_filter_symbols += /^py_create_dissector_handle/ || /^py_dissector_args/ {next;};
+def_sym_filter_symbols += /^py_generic_dissector/ || /^py_pinfo/ || /^py_tree/ || /^py_tvbuff/ {next;};
+def_sym_filter_symbols += /^hf_register_info_add/ || /^hf_register_info_create/ || /^hf_register_info_destroy/ {next;};
+endif
+
if HAVE_PLUGINS
if ENABLE_STATIC