aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-12-03 21:01:18 -0800
committerGuy Harris <guy@alum.mit.edu>2017-12-04 05:02:18 +0000
commit1834dca3654ccec238bae130715871be3d8fa344 (patch)
tree5f1de666575b16f58be5a2f7b4e40cc5b93c02dc /epan/Makefile.am
parent02944c412b4d9d7661c0a2b3eb9df44d632878ee (diff)
Move the parts of a capture_file used by libwireshark to a new structure.
Embed one of those structures in a capture_file, and have a struct epan_session point to that structure rather than to a capture_file. Pass that structure to the routines that fetch data that libwireshark uses when dissecting. That separates the stuff that libwireshark expects from the stuff that it doesn't look at. Change-Id: Ia3cd28efb9622476437a2ce32204597fae720877 Reviewed-on: https://code.wireshark.org/review/24692 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index ac62ba9a68..87bc04d4b7 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -67,11 +67,11 @@ LIBWIRESHARK_SRC = \
expert.c \
export_object.c \
exported_pdu.c \
- plugin_if.c \
filter_expressions.c \
follow.c \
frame_data.c \
frame_data_sequence.c \
+ frame_set.c \
funnel.c \
geoip_db.c \
golay.c \
@@ -84,6 +84,7 @@ LIBWIRESHARK_SRC = \
oids.c \
osi-utils.c \
packet.c \
+ plugin_if.c \
prefs.c \
print.c \
print_stream.c \
@@ -207,11 +208,11 @@ LIBWIRESHARK_INCLUDES_PUBLIC = \
expert.h \
export_object.h \
exported_pdu.h \
- plugin_if.h \
filter_expressions.h \
follow.h \
frame_data.h \
frame_data_sequence.h \
+ frame_set.h \
funnel.h \
garrayfix.h \
geoip_db.h \
@@ -235,6 +236,7 @@ LIBWIRESHARK_INCLUDES_PUBLIC = \
packet.h \
packet_info.h \
params.h \
+ plugin_if.h \
ppptypes.h \
print.h \
print_stream.h \