aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2012-09-07 02:20:29 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2012-09-07 02:20:29 +0000
commit6dc8a84eab3578fa33f325e2d237ce29e6829770 (patch)
tree38e059c4682bff5cb0569cd063ff4d4ac1467479 /epan/Makefile.am
parentaa5d9d78ddcb4b7066ab03afa4277fab0bf0f468 (diff)
From pi-rho via https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7403 :
Correct a logic error which filtered out the Python-related library symbols when Python is enabled. Actually expose some Python-related symbols (which get filtered out if it's not enabled). svn path=/trunk/; revision=44803
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index b2c6c6f10c..1981a204fc 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -195,7 +195,7 @@ if !HAVE_PLUGINS
def_sym_filter_symbols += /^register_all_wiretap_modules/ || /^register_all_plugin_tap_listeners/ || /^plugin_list/ {next;};
endif
-if HAVE_LIBPY
+if !HAVE_LIBPY
# If we're not building python, these symbols don't get built.
# Keep them out of the symbol list.
def_sym_filter_symbols += /^py_create_dissector_handle/ || /^py_dissector_args/ {next;};