aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorrbalint <rbalint@f5534014-38df-0310-8fa8-9805f1628bb7>2010-12-07 13:38:15 +0000
committerrbalint <rbalint@f5534014-38df-0310-8fa8-9805f1628bb7>2010-12-07 13:38:15 +0000
commitb3aac9f1af9a929b0716bbf57e08ff522c876dd6 (patch)
treeb4713a77e65d554d3a2ef994f32fa9e96ba5c905 /epan/Makefile.am
parent6a9f7155e2c2d5ef6bf443470b031d76ba8d62d7 (diff)
Make libtool export only symbols listed in *.def files
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@35145 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 5ad26e8a56..738aa0f896 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -54,7 +54,7 @@ ACLOCAL_AMFLAGS = `../aclocal-flags`
noinst_LTLIBRARIES = libwireshark_generated.la libwireshark_asmopt.la
lib_LTLIBRARIES = libwireshark.la
-libwireshark_la_LDFLAGS = -version-info 0:1:0 @LDFLAGS_SHAREDLIB@
+libwireshark_la_LDFLAGS = -version-info 0:1:0 -export-symbols libwireshark.sym @LDFLAGS_SHAREDLIB@
include Makefile.common
@@ -113,6 +113,7 @@ CLEANFILES = \
libwireshark_generated.la \
libwireshark_asmopt.a \
libwireshark_asmopt.la \
+ libwireshark.sym \
*~
DISTCLEANFILES = \
@@ -145,7 +146,8 @@ libwireshark_la_DEPENDENCIES = \
ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
dissectors/libdirtydissectors.la $(wslua_lib) $(wspython_lib) \
${top_builddir}/wsutil/libwsutil.la \
- ${top_builddir}/wiretap/libwiretap.la
+ ${top_builddir}/wiretap/libwiretap.la \
+ libwireshark.sym
#EXTRA_PROGRAMS = reassemble_test
#reassemble_test_LDADD = $(GLIB_LIBS)