aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2014-04-23 10:50:27 +0200
committerAnders Broman <a.broman58@gmail.com>2014-04-25 04:23:46 +0000
commitbd38b3152d12584b9cd31d0c49706f1cebaa087a (patch)
treedd9ffd4b9f64647e9c683085b0fb73337132a7ab /epan/Makefile.am
parent748e0d4221eabab207a350640ce3f526c73afde9 (diff)
Support out-of-source checkapi
Always call $(top_srcdir)/tools/checkAPIs.pl with -sourcedir=$(srcdir) from Makefile.am to allow out-of-source 'make checkapi'. Change-Id: I60d7e0079984a8ededdacf4517a0738486fa7973 Reviewed-on: https://code.wireshark.org/review/1294 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 58f622286b..dc54506cd7 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -332,4 +332,6 @@ dumpabi-libwireshark: all abi-descriptor.xml
cd .libs && ln -sf libwireshark_*.abi.tar.gz libwireshark.abi.tar.gz
checkapi:
- $(AM_V_GEN)$(PERL) ../tools/checkAPIs.pl -g termoutput -build $(LIBWIRESHARK_SRC)
+ $(AM_V_GEN)$(PERL) $(top_srcdir)/tools/checkAPIs.pl -g termoutput -build \
+ -sourcedir=$(srcdir) \
+ $(LIBWIRESHARK_SRC)