aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-19 08:03:08 +0100
committerJoão Valverde <j@v6e.pt>2016-04-21 18:59:56 +0000
commit3db13a7fc9f08fdb238f06e73a42b39396fee84c (patch)
tree13962d67e01b8d0f15aed5e6216ae584c23bd991 /epan/Makefile.am
parent7c6e859ccf210a45e1cc0f6da17692845e6b5a23 (diff)
Link version code statically again
This allows keeping the code-sharing with the static linking. This "fixes" a hypothetical ABI mismatch with wsutil and avoids pulling more external dependencies to wsutil than strictly necessary. A nice side-effect is that libwsutil no longer depends on version.h. Follow up to f95976eefcbeb5d24df383c29d29ef888b503945. Change-Id: I8f0d6a557ab3f7ce6f0e2c269124c89f29d6ad23 Reviewed-on: https://code.wireshark.org/review/15002 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index a7af0d83a2..f16ce7ff42 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -54,7 +54,8 @@ libwireshark_la_LDFLAGS = -version-info 0:0:0 @LDFLAGS_SHAREDLIB@
#files with the "stop on warning" barrier.
libwireshark_la_SOURCES = \
$(LIBWIRESHARK_SRC) \
- $(LIBWIRESHARK_INCLUDES)
+ $(LIBWIRESHARK_INCLUDES) \
+ ws_version_info.c
libwireshark_la_CPPFLAGS = $(AM_CPPFLAGS) -DWS_BUILD_DLL
@@ -104,7 +105,8 @@ CLEANFILES = \
DISTCLEANFILES = \
$(NODIST_LIBWIRESHARK_GENERATED_C_FILES) \
$(NODIST_LIBWIRESHARK_GENERATED_HEADER_FILES) \
- dtd_grammar.out
+ dtd_grammar.out \
+ ws_version_info.c
MAINTAINERCLEANFILES = \
$(LIBWIRESHARK_GENERATED_C_FILES) \
@@ -113,7 +115,8 @@ MAINTAINERCLEANFILES = \
BUILT_SOURCES = \
$(LIBWIRESHARK_GENERATED_HEADER_FILES) \
- $(NODIST_LIBWIRESHARK_GENERATED_HEADER_FILES)
+ $(NODIST_LIBWIRESHARK_GENERATED_HEADER_FILES) \
+ ws_version_info.c
#
# Add the object files for missing routines, if any.
@@ -194,6 +197,9 @@ dtd_grammar.h: dtd_grammar.c
dtd_grammar.c : $(LEMON) $(lemon_srcdir)/lempar.c $(srcdir)/dtd_grammar.lemon
$(AM_V_LEMON)$(LEMON) T=$(lemon_srcdir)/lempar.c $(srcdir)/dtd_grammar.lemon
+ws_version_info.c: $(top_srcdir)/ws_version_info.c
+ $(LN_S) $<
+
tvbtest.o exntest.o oids_test.o: exceptions.h
update-sminmpec: