aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-19 06:14:10 +0000
committerJoão Valverde <j@v6e.pt>2016-03-03 03:49:08 +0000
commit2bded0b66137a2f1c8b69911d91903a24f8a2624 (patch)
tree0dbcc0a6479b8b29fd6487e3107db39dd4dfcb1a /epan/Makefile.am
parent4fca15308968d6fd526eb67497148d2cd6c0b703 (diff)
autotools: Use explicit zlib dependency build flags
Use pkg-config if a zlib.pc file is available. Remove the now redundant AC_TRY_LINK_FUNC test (there are no linker flags for GTK+ here). Change-Id: I7de744749eba7231ae0097b975144b76ffcf1bdb Reviewed-on: https://code.wireshark.org/review/14263 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index dd192a7a25..b64d4de846 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -43,7 +43,7 @@ ACLOCAL_AMFLAGS = `../aclocal-flags`
AM_CPPFLAGS = $(INCLUDEDIRS) -I$(builddir)/wslua $(WS_CPPFLAGS) \
$(GLIB_CFLAGS) $(LUA_CFLAGS) $(LIBGNUTLS_CFLAGS) \
$(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) $(LIBGEOIP_CFLAGS) \
- $(KRB5_CFLAGS)
+ $(KRB5_CFLAGS) $(ZLIB_CFLAGS)
noinst_LTLIBRARIES = libwireshark_generated.la libwireshark_asmopt.la
lib_LTLIBRARIES = libwireshark.la
@@ -147,6 +147,7 @@ libwireshark_la_LIBADD = \
@LIBSMI_LDFLAGS@ \
@GEOIP_LIBS@ \
@GLIB_LIBS@ \
+ $(ZLIB_LIBS) \
-lm
libwireshark_la_DEPENDENCIES = \
@@ -168,17 +169,17 @@ EXTRA_PROGRAMS = reassemble_test tvbtest oids_test
reassemble_test_LDADD = \
libwireshark.la \
$(GLIB_LIBS) \
- -lz
+ $(ZLIB_LIBS)
tvbtest_LDADD = \
libwireshark.la \
$(GLIB_LIBS) \
- -lz
+ $(ZLIB_LIBS)
oids_test_LDADD = \
libwireshark.la \
$(GLIB_LIBS) \
- -lz
+ $(ZLIB_LIBS)
exntest: exntest.o except.o
$(LINK) $^ $(GLIB_LIBS)