aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2005-08-04 13:54:46 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2005-08-04 13:54:46 +0000
commitc8cd8f21a4431b1880ce3360553e0abd4861cf99 (patch)
tree27a5d61208c07301e13843fac71cef1a58cb686c /epan/Makefile.am
parent2c65361b8a25d69d560dfc88d4abf14e91cd1dbd (diff)
Exception handling fixes, and a fix to packet-frame.c,
from Richard van der Hoff. svn path=/trunk/; revision=15205
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index ca564fe335..f0de38dd4c 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -57,6 +57,7 @@ EXTRA_DIST = \
make-sminmpec.pl \
radius_dict.l \
tvbtest.c \
+ exntest.c \
doxygen.cfg.in
CLEANFILES = \
@@ -77,11 +78,16 @@ libethereal_la_LIBADD = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INE
libethereal_la_DEPENDENCIES = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la
tvbtest: tvbtest.o tvbuff.o except.o strutil.o
- $(LINK) -o tvbtest tvbtest.o tvbuff.o except.o strutil.o `glib-config --libs`
+ $(LINK) $^ $(GLIB_LIBS) -lz
+
+exntest: exntest.o except.o
+ $(LINK) $^ $(GLIB_LIBS)
radius_dict.c: radius_dict.l
$(LEX) radius_dict.l
+tvbtest.o exntest.o: exceptions.h
+
sminmpec.c: enterprise-numbers make-sminmpec.pl
$(PERL) make-sminmpec.pl enterprise-numbers sminmpec.c