aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2007-07-30 20:22:37 +0000
committerGuy Harris <guy@alum.mit.edu>2007-07-30 20:22:37 +0000
commit968d363f113c73885a4c6c67019b0b8a93bf2524 (patch)
tree9cbfb86dfe1b0a83c37e8528dc019ef3885e0733 /epan/Makefile.am
parent0d437580eed2149e0d313aa00a64c11a4df37633 (diff)
Add comments to various %option items to explain what they're doing.
Move the %options to the beginning if they weren't already there, and put them in the same order in all files. Add "prefix=" options to .l files that don't already have them, so we don't have to pass a "-P" option. Add "never-interactive" and "noyywrap" options to our lexical analyzers, to remove extra isatty() checks and to eliminate the need for yywrap() from the Flex library. Get rid of %option nostdinit - that's the default. Add .l.c: rules to Makefile.am files, replacing the rules for specific .l files. Have those rules all check that $(LEX) is set. Update the address for the FSF. svn path=/trunk/; revision=22424
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am20
1 files changed, 6 insertions, 14 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 8522d07b34..1b8b29c613 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -125,20 +125,12 @@ tvbtest: tvbtest.o tvbuff.o except.o strutil.o emem.o
exntest: exntest.o except.o
$(LINK) $^ $(GLIB_LIBS)
-radius_dict.c: radius_dict.l
- $(LEX) $^
-
-uat_load.c: uat_load.l
- $(LEX) -ouat_load.c $(srcdir)/uat_load.l
-
-diam_dict.c: diam_dict.l
- $(LEX) -odiam_dict.c $(srcdir)/diam_dict.l
-
-dtd_parse.c : dtd_parse.l
- $(LEX) -odtd_parse.c $(srcdir)/dtd_parse.l
-
-dtd_preparse.c : dtd_preparse.l
- $(LEX) -odtd_preparse.c $(srcdir)/dtd_preparse.l
+.l.c:
+ @if [ ! -x "$(LEX)" ]; then \
+ echo "Neither lex nor flex was found"; \
+ exit 1; \
+ fi
+ $(LEX) -o$@ $<
dtd_grammar.h: dtd_grammar.c