aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2017-11-11 17:16:13 -0500
committerAnders Broman <a.broman58@gmail.com>2017-11-13 05:21:36 +0000
commit800b26edbe34e135cc9be1d4395db2c13ae1213f (patch)
treefae0a8da631334bde17966a4e7a6a5c0f4491f71 /epan/CMakeLists.txt
parent7c40580584eac67a23633e58810028dddc58781c (diff)
Remove circuit API
Replace with conversation API that limits the "endpoint" to a single uint32 value. The intention is to eventually have "layered" endpoints, because circuit_id was used in cases where src/dest port have already been populated (and are used for layers above). Those src/dest ports should just be treated as just another endpoint, but we currently only have support for one. Change-Id: Ic6aa7ef0241275aa4dfde9459194369b48c72960 Reviewed-on: https://code.wireshark.org/review/24369 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 7883464090..a4842ca40a 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -68,7 +68,6 @@ set(LIBWIRESHARK_PUBLIC_HEADERS
capture_dissectors.h
charsets.h
chdlctypes.h
- circuit.h
color_filters.h
column.h
column-info.h
@@ -184,7 +183,6 @@ set(LIBWIRESHARK_FILES
asn1.c
capture_dissectors.c
charsets.c
- circuit.c
color_filters.c
column.c
column-utils.c