aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-09-30 16:06:15 +0200
committerDario Lombardo <lomato@gmail.com>2016-09-30 20:08:02 +0000
commit534787e402d6aa8b349638f911a2a65b013c6594 (patch)
tree9cfaeb38a16eab0fee86b3b0fb8f9245c7813f7a /epan/CMakeLists.txt
parent53c91974c7e8f77555920e137cab80b5418e992b (diff)
cmake: make WERROR_COMMON_FLAGS a normal string
Instead of checking for the boolean "FALSE", just set an empty string. This avoids the need to check for WERROR_COMMON_FLAGS before using it. The transformation is the same for all files, remove "if (WERROR_COMMON_FLAGS)" and "endif()", reindent and add quotes (since we have a string here and not a list). Modelines have been added where missing. Change-Id: I0ab05ae507c51fa77336d49a99a226399cc81b92 Reviewed-on: https://code.wireshark.org/review/17997 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Dario Lombardo <lomato@gmail.com> Tested-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 5cbd206d3d..25f8460d8c 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -209,13 +209,11 @@ set(CLEAN_FILES
${LIBWIRESHARK_ASM_FILES}
)
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
# Cannot use $<$<BOOL:${HAVE_LIBLUA}>:$<TARGET_OBJECTS:wslua>> as that breaks
# get_target_property(_libwireshark_location epan LOCATION).