aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorDániel Bakai <bakaidl@gmail.com>2019-04-10 12:52:52 +0200
committerPeter Wu <peter@lekensteyn.nl>2019-04-22 15:24:46 +0000
commit9ce60b173bf17b7d20695d9dc1de050989019664 (patch)
tree95ec8b8554415ef2c80d6d9950cc9201c8d22c94 /epan/CMakeLists.txt
parent51ac1047a7e434a0b2e264780b2fa31f1d986898 (diff)
Add brotli decompression support for HTTP and HTTP2 dissectors.
Change-Id: I9c09f55673187f6fee723fcd72798fb6b9958b03 Reviewed-on: https://code.wireshark.org/review/32745 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index bd13510591..2cd73eaceb 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -16,6 +16,7 @@ if (HAVE_HFI_SECTION_INIT)
endif()
include_directories(
+ ${BROTLI_INCLUDE_DIRS}
${GLIB2_INCLUDE_DIRS}
${CARES_INCLUDE_DIRS}
${GCRYPT_INCLUDE_DIRS}
@@ -265,6 +266,7 @@ set(LIBWIRESHARK_NONGENERATED_FILES
tvbparse.c
tvbuff.c
tvbuff_base64.c
+ tvbuff_brotli.c
tvbuff_composite.c
tvbuff_real.c
tvbuff_subset.c
@@ -378,6 +380,7 @@ target_link_libraries(epan
wsutil
${GLIB2_LIBRARIES}
PRIVATE
+ ${BROTLI_LIBRARIES}
${CARES_LIBRARIES}
${GCRYPT_LIBRARIES}
${GIO2_LIBRARIES}