aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorPascal Quantin <pascal.quantin@gmail.com>2016-06-13 15:11:55 -0700
committerPeter Wu <peter@lekensteyn.nl>2016-06-14 21:57:41 +0000
commit581a17af40b84ef0c9e7f41ed0795af345b61ce1 (patch)
tree9ae8ce021ea67301d083a33b5c2e81ee85abe97c /epan/CMakeLists.txt
parentd74113fbfb87d0f33a2d93063ac4e0e09d1bca2a (diff)
CORBA IDL: compile dissectors with /Ox when using MSVC2013 x64
By default Windows files are compiled with /O2 optimization flag (that brings the best performance). But MSVC2013 x64 compiler generates buggy code for CORBA IDL dissectors. Let's downgrade the optimization to /Ox for those files specifically. Bug: 12495 Change-Id: Ibbb532653808d915c82bd20b55dd9e68d86b1207 Reviewed-on: https://code.wireshark.org/review/15884 Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 5ac91ebf61..4c06ada5c6 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -232,6 +232,7 @@ add_library(epan ${LINK_MODE_LIB}
$<TARGET_OBJECTS:crypt>
$<TARGET_OBJECTS:dfilter>
$<TARGET_OBJECTS:dissectors>
+ $<TARGET_OBJECTS:dissectors-corba>
$<TARGET_OBJECTS:ftypes>
$<TARGET_OBJECTS:nghttp2>
$<TARGET_OBJECTS:wmem>