aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2018-01-15 21:54:17 +0100
committerDario Lombardo <lomato@gmail.com>2018-01-18 11:01:38 +0000
commitde0872971ad613b865464e160f30c4c4f0519bc7 (patch)
treef13a39a81949a466107c64802b7bc3ed94567264 /epan/CMakeLists.txt
parent2996ef23044dc1e082c14675a9f3fee80661b7ad (diff)
cmake: add ps.c to the checkAPI list with the proper path.
This removes an error when running cmake target checkAPI_epan. No such file: "ps.c" at wireshark/tools/checkAPIs.pl line 2144. This error is related to out-of-tree builds. In-tree builds are not affected since the generated files live next to the versioned ones. Change-Id: I3a6b05eaf4b7bb703222c47233576d0cb77e66d1 Reviewed-on: https://code.wireshark.org/review/25330 Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 1ad2bfedf8..9a8f38145f 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -225,7 +225,6 @@ set(LIBWIRESHARK_FILES
prefs.c
proto.c
proto_data.c
- ps.c
range.c
reassemble.c
reedsolomon.c
@@ -256,6 +255,7 @@ set(LIBWIRESHARK_FILES
value_string.c
unit_strings.c
xdlc.c
+ ${CMAKE_CURRENT_BINARY_DIR}/ps.c
${CMAKE_SOURCE_DIR}/version_info.c
)