aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthieu Coudron <mattator@gmail.com>2015-11-11 03:19:43 +0100
committerGuy Harris <guy@alum.mit.edu>2015-11-24 23:02:09 +0000
commitbd08ab920dd9e24c37c04dc049ce234285a337fb (patch)
tree9a17e1f2716dd576be77d72f4dae66de2cc13fc2 /epan/CMakeLists.txt
parent9601a4f724492b3f9960e1f051360b071997d7d6 (diff)
Introduces augmented interval trees
Interval trees (wmem_itree_t) are implemented as an extension of wmem_tree with a guint64-based range as the key. This is useful for instance in MPTCP analysis, to look for packets matching a range defined by a mapping across TCP subflows. Change-Id: Iea706d44fe975e390a4191ad0257ef37d5c71525 Reviewed-on: https://code.wireshark.org/review/11714 Reviewed-by: Evan Huus <eapache@gmail.com> Petri-Dish: Evan Huus <eapache@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index fe468c5534..5bb903cab4 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -1545,6 +1545,7 @@ set(WMEM_FILES
wmem/wmem_allocator_block_fast.c
wmem/wmem_allocator_simple.c
wmem/wmem_allocator_strict.c
+ wmem/wmem_interval_tree.c
wmem/wmem_list.c
wmem/wmem_map.c
wmem/wmem_miscutl.c