aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorChuan He <bupthc@gmail.com>2016-01-13 16:07:12 -0800
committerAnders Broman <a.broman58@gmail.com>2016-01-20 21:07:21 +0000
commit92f76d0b696a165fa3f3cd8724aee8d2c816a6d5 (patch)
treee58e206ea0eb0a12a07c64d946e1f7ef3b9d0c40 /epan/CMakeLists.txt
parentdced679fcc625da2bd0a1a342e052986026424d3 (diff)
IPOS: Add Ericsson IPOS kernel packet header dissector
IPOS is the networking operating system used in Ericsson's SSR 8000, Router 6000, and SP routers, etc.. This change added the IPOS kernel packet header dissector. The change creates a new file for IPOS protocol named "packet-ipos.c". IPOS will register sub dissectors with the dissect table "sll_linux_dissector_table" for IPOS internal ethernet packet types. IPOS dissector also calls the existing REDBACK dissector. Change-Id: I642b932010be6aa05314f21ea8596d1c45eacf5b Reviewed-on: https://code.wireshark.org/review/13408 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 20ca5fc6cf..08bb351515 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -858,6 +858,7 @@ set(DISSECTOR_SRC
dissectors/packet-ipmi-vita.c
dissectors/packet-ipnet.c
dissectors/packet-ipoib.c
+ dissectors/packet-ipos.c
dissectors/packet-ipp.c
dissectors/packet-ipsec-tcp.c
dissectors/packet-ipsec-udp.c