aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-11-20 18:52:02 -0800
committerGuy Harris <guy@alum.mit.edu>2015-11-21 02:52:57 +0000
commit91f4e3b73d6929591d6b0790c7e1a4c1810f045d (patch)
treee46395c93860ba78d20177254f0fb539ddcb2cd4 /epan/CMakeLists.txt
parentfef4714e7255572ec40a877ccf7fb7ca76eb90dc (diff)
Have a separate dissector for pcap/pcapng-format packet data.
Put that dissector into its own file, and get handles for it from the pcap and pcapng file dissectors. Put the value_string of pcap/pcapng LINKTYPE_ values there, and have the pcap and pcapng file dissectors import it. Expand that table to include all LINKTYPE_ values in the current libpcap. Change-Id: I9397035efa5711e8a18a26e056d3b54494fd3148 Reviewed-on: https://code.wireshark.org/review/12000 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index f181887316..6635e75ece 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -259,6 +259,7 @@ set(ASN1_DISSECTOR_SRC
dissectors/packet-p7.c
dissectors/packet-p772.c
dissectors/packet-pcap.c
+ dissectors/packet-pcap_pktdata.c
dissectors/packet-pkcs1.c
dissectors/packet-pkcs12.c
dissectors/packet-pkinit.c