aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-06-24 14:25:41 +0100
committerJoão Valverde <j@v6e.pt>2017-06-26 22:40:50 +0000
commit7466880e8a09aa7a9bb797b70fa44bca397881d9 (patch)
tree1634c5d6e433a4803ecd5543a4cb6420e7c886d7 /epan/CMakeLists.txt
parent3071f9dd7409bd5b0432dd8f1bebbeeee1b6c755 (diff)
Parse enterprise-numbers at run time
"enterprise-numbers" is converted to tab-separated values and renamed "enterprises". Unused fields are stripped. PENs are stored in a hash table loaded at run-time. User "enterprises" file is loaded from the personal config dir. Misc make-sminmpec.pl improvements and fixes. Note: names of type "Entity (formerly ...)" have the formerly part commented out for a cleaner output. Change-Id: I60c533afbe3e399077fbf432088064471ad3e1e2 Reviewed-on: https://code.wireshark.org/review/22246 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 1d3c7ac150..0dcbc4b55a 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -61,16 +61,6 @@ set(LIBWIRESHARK_ASM_FILES
# !ENDIF
)
-add_custom_target(
- update-sminmpec
- COMMAND ${PERL_EXECUTABLE}
- ${CMAKE_SOURCE_DIR}/tools/make-sminmpec.pl
- DEPENDS
- enterprise-numbers
- ${CMAKE_SOURCE_DIR}/tools/make-sminmpec.pl
-)
-set_target_properties(update-sminmpec PROPERTIES FOLDER "tools")
-
add_custom_command(
OUTPUT ps.c
COMMAND ${PYTHON_EXECUTABLE}
@@ -145,7 +135,6 @@ set(LIBWIRESHARK_FILES
req_resp_hdrs.c
rtd_table.c
show_exception.c
- sminmpec.c
srt_table.c
stat_tap_ui.c
stats_tree.c