aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorGregor Beck <gbeck@sernet.de>2012-09-17 13:22:32 +0200
committerAnders Broman <a.broman58@gmail.com>2015-07-25 12:58:35 +0000
commitc425334394ea22b55a48b282a77553584ede4efc (patch)
treef5b59c675d60637328cdc55d922780042a865815 /epan/CMakeLists.txt
parent23ca45603568e1288c44bc69fd5bf55c290d275c (diff)
MSWSP: Initial implementation of MS-WSP (windows search protocol) dissector
This changeset is a forward port of Gregors ms-wsp branch from his repo http://repo.or.cz/w/wireshark-wip.git. Most of the messages of the MS-WSP protocol are implemented here and as such consists of the majority of the changes for the dissector. In addition to the forward porting Gregors work I added some extra bits 1) cater for SMB2 Read Response and Write Request msgs that can also contain MSWSP messages 2) update property specifications with info extracted from MS-WSP protocol doc 3) store some basic data about previously seen messages that are needed for dissecting CPMGetRows request 4) expand/update dissect_CPMSetBindings & parse_CTableColumn routines 5) parse and store CTableColumn & CPMSetBindingsIn structures in conversation related data for use later. 6) fully dissect/parse SeekDesciption of CPMGetRowsOut 7) dissect CPMGetRows out message specifically the Rows & Columns 8) flesh out the boolean properties of uBooleanOptions field 9) flesh out various other dissectors: CPMRatioFinished CPMRestartPosition CPMCompareBmkIn/CPMCompareBmkOut CPMGetApproximatePosition CPMGetSendNotifyOut FindIndicesIn/Out FetchValue Bug: 11321 Change-Id: I68b5c2f3e63874c1dbb271feab89b2b8aa65ac39 Signed-off-by: Noel Power <noel.power@suse.com> Reviewed-on: https://code.wireshark.org/review/9440 Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index cf0a2d9c62..50c02b83d7 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -1026,6 +1026,7 @@ set(DISSECTOR_SRC
dissectors/packet-msproxy.c
dissectors/packet-msrp.c
dissectors/packet-mstp.c
+ dissectors/packet-mswsp.c
dissectors/packet-mtp2.c
dissectors/packet-mtp3.c
dissectors/packet-mtp3mg.c