aboutsummaryrefslogtreecommitdiffstats
path: root/echld/Makefile.am
diff options
context:
space:
mode:
authorLuis Ontanon <luis.ontanon@gmail.com>2013-06-25 00:31:01 +0000
committerLuis Ontanon <luis.ontanon@gmail.com>2013-06-25 00:31:01 +0000
commite591c9f21e5d57be7a9cad4e9c5d62647bde38eb (patch)
tree497b333d291fd13bf9b5d2faada68fc4c49156c3 /echld/Makefile.am
parentcf7a0dde683bd9f5784b66b67b989ddf81e88235 (diff)
more stuff...
svn path=/trunk/; revision=50135
Diffstat (limited to 'echld/Makefile.am')
-rw-r--r--echld/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/echld/Makefile.am b/echld/Makefile.am
index e40ee5718d..6dfb03d0b8 100644
--- a/echld/Makefile.am
+++ b/echld/Makefile.am
@@ -36,6 +36,7 @@ if HAVE_WARNINGS_AS_ERRORS
AM_CFLAGS += -Werror
endif
+
lib_LTLIBRARIES = libechld.la
# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
libechld_la_LDFLAGS = -version-info 0:0:0 @LDFLAGS_SHAREDLIB@
@@ -66,6 +67,17 @@ CLEANFILES = \
MAINTAINERCLEANFILES = \
Makefile.in
+bin_PROGRAMS =
+ @echld_test_bin@
+
+EXTRA_PROGRAMS = echld_test
+
+echld_test_LDADD = \
+ echld/libechld.la \
+ @GLIB_LIBS@
+
+echld_test_CFLAGS = $(AM_CLEAN_CFLAGS)
+
# ABI compliance checker can be obtained from
# http://ispras.linux-foundation.org/index.php/ABI_compliance_checker
# Checked using version 1.21.12