aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@zing.org>2014-07-23 18:28:32 -0700
committerGerald Combs <gerald@wireshark.org>2014-08-24 02:56:35 +0000
commitd31011572def589f5c7926c780e0e82a3f61216d (patch)
tree0d534d0ffae5b989c8d2374e97c9658cbd65245e /docbook/Makefile.am
parent7d035a12b3762fccfd28694dd1ade2c8cd72ea7f (diff)
Convert admon graphics to SVG.
Use a common set of SVG files for AsciiDoc / DocBook admonition graphics. Put them in a common directory. According to http://caniuse.com/svg all common browsers have had SVG support for a while now. The graphics themselves were created with Inkscape. If you would like to refine them further you are more than welcome. Use variables to assemble xsltproc commands in Autotools and Nmake while we're here. Try to update Debian rules to reflect ga92c3fb. Change-Id: If82647af27a60117c517125dff0aca81c033be72 Reviewed-on: https://code.wireshark.org/review/3206 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'docbook/Makefile.am')
-rw-r--r--docbook/Makefile.am33
1 files changed, 12 insertions, 21 deletions
diff --git a/docbook/Makefile.am b/docbook/Makefile.am
index 2ab4929106..8e3cfffca2 100644
--- a/docbook/Makefile.am
+++ b/docbook/Makefile.am
@@ -112,14 +112,11 @@ wsug_html/index.html: $(WSUG_SOURCE) wsluarm
@ echo --- WSUG - HTML SINGLE PAGE ---
mkdir -p wsug_html/wsug_graphics/toolbar
cp $(srcdir)/wsug_graphics/*.* wsug_html/wsug_graphics
+ cp $(srcdir)/common_graphics/*.* wsug_html/wsug_graphics
cp $(srcdir)/wsug_graphics/toolbar/* wsug_html/wsug_graphics/toolbar
cp $(srcdir)/ws.css wsug_html
- $(XSLTPROC) --stringparam base.dir wsug_html/ --stringparam use.id.as.filename 1 \
- --stringparam admon.graphics 1 --stringparam admon.graphics.path wsug_graphics/ \
- --stringparam section.autolabel 1 --stringparam section.label.includes.component.label 1 \
- --stringparam html.stylesheet ws.css \
- --path .:wsluarm_src \
- --nonet http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< > $@
+ $(XSLTPROC) --stringparam base.dir wsug_html/ $(COMMON_XSLTPROC_ARGS) \
+ --path .:wsluarm_src $(SINGLE_XSLTPROC_ARGS) $< > $@
-chmod -R og+rX wsug_html
# create html chunked page files
@@ -129,14 +126,12 @@ wsug_html_chunked/index.html: $(WSUG_SOURCE) wsluarm
@ echo --- WSUG - HTML CHUNKED ---
mkdir -p wsug_html_chunked/wsug_graphics/toolbar
cp $(srcdir)/wsug_graphics/*.* wsug_html_chunked/wsug_graphics
+ cp $(srcdir)/common_graphics/*.* wsug_html_chunked/wsug_graphics
cp $(srcdir)/wsug_graphics/toolbar/* wsug_html_chunked/wsug_graphics/toolbar
cp $(srcdir)/ws.css wsug_html_chunked
- $(XSLTPROC) --stringparam base.dir wsug_html_chunked/ --stringparam use.id.as.filename 1 \
- --stringparam admon.graphics 1 --stringparam admon.graphics.path wsug_graphics/ \
- --stringparam section.autolabel 1 --stringparam section.label.includes.component.label 1 \
- --stringparam html.stylesheet ws.css \
+ $(XSLTPROC) --stringparam base.dir wsug_html_chunked/ $(COMMON_XSLTPROC_ARGS) \
--path .:wsluarm_src \
- --nonet http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl $<
+ $(CHUNKED_XSLTPROC_ARGS) $<
-chmod -R og+rX wsug_html_chunked
# create pdf file (through XSL-FO), portrait pages on US letter paper
@@ -199,13 +194,11 @@ wsdg_html/index.html: $(WSDG_SOURCE)
@ echo --- WSDG - HTML SINGLE PAGE ---
mkdir -p wsdg_html/wsdg_graphics/toolbar
cp $(srcdir)/wsdg_graphics/*.* wsdg_html/wsdg_graphics
+ cp $(srcdir)/common_graphics/*.* wsdg_html/wsdg_graphics
cp $(srcdir)/wsdg_graphics/toolbar/* wsdg_html/wsdg_graphics/toolbar/
cp $(srcdir)/ws.css wsdg_html
- $(XSLTPROC) --stringparam base.dir wsdg_html/ --stringparam use.id.as.filename 1 \
- --stringparam admon.graphics 1 --stringparam admon.graphics.path wsdg_graphics/ \
- --stringparam section.autolabel 1 --stringparam section.label.includes.component.label 1 \
- --stringparam html.stylesheet ws.css \
- --nonet http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< > $@
+ $(XSLTPROC) --stringparam base.dir wsdg_html/ $(COMMON_XSLTPROC_ARGS) \
+ $(SINGLE_XSLTPROC_ARGS) $< > $@
-chmod -R og+rX wsdg_html
# create html chunked page files
@@ -215,13 +208,11 @@ wsdg_html_chunked/index.html: $(WSDG_SOURCE)
@ echo --- WSDG - HTML CHUNKED ---
mkdir -p wsdg_html_chunked/wsdg_graphics/toolbar
cp $(srcdir)/wsdg_graphics/*.* wsdg_html_chunked/wsdg_graphics
+ cp $(srcdir)/common_graphics/*.* wsdg_html_chunked/wsdg_graphics
cp $(srcdir)/wsdg_graphics/toolbar/* wsdg_html_chunked/wsdg_graphics/toolbar/
cp $(srcdir)/ws.css wsdg_html_chunked
- $(XSLTPROC) --stringparam base.dir wsdg_html_chunked/ --stringparam use.id.as.filename 1 \
- --stringparam admon.graphics 1 --stringparam admon.graphics.path wsdg_graphics/ \
- --stringparam section.autolabel 1 --stringparam section.label.includes.component.label 1 \
- --stringparam html.stylesheet ws.css \
- --nonet http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl $<
+ $(XSLTPROC) --stringparam base.dir wsdg_html_chunked/ $(COMMON_XSLTPROC_ARGS) \
+ $(CHUNKED_XSLTPROC_ARGS) $<
-chmod -R og+rX wsdg_html_chunked
# create pdf file (through XSL-FO), portrait pages on US letter paper