aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-01-23 11:02:16 -0800
committerGerald Combs <gerald@wireshark.org>2018-01-23 22:15:01 +0000
commit787b93fd071e1537b33e8d2f894bbc3cc0ed5595 (patch)
tree8fac31366ccc4a0789e85d5e695fa63e7169d795 /docbook/CMakeLists.txt
parent6605d844afa3d804da89970ee46845cfa986994b (diff)
Docbook: Generate one PDF paper size.
Generate a single PA4-sized PDF. PA4 is the approximate intersection of A4 and Letter[1]. This gives us one less file to build and distribute. If you're printing out hard copies of the guides this wastes a few pages compared to an A4-sized PDF, but if you're printing out hard copies of the guides you've already made a strong commitment to waste paper. Page counts: Guide Size Pages WSDG A4 203 WSDG Letter 217 WSDG PA4 217 WSUG A4 192 WSUG Letter 204 WSUG PA4 205 [1] https://en.wikipedia.org/wiki/Paper_size#PA4_or_L4 Change-Id: If43d4b19947c77a51b3943a2b329dbab45025d79 Reviewed-on: https://code.wireshark.org/review/25438 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'docbook/CMakeLists.txt')
-rw-r--r--docbook/CMakeLists.txt69
1 files changed, 12 insertions, 57 deletions
diff --git a/docbook/CMakeLists.txt b/docbook/CMakeLists.txt
index bfde3c0019..18f38b3b2c 100644
--- a/docbook/CMakeLists.txt
+++ b/docbook/CMakeLists.txt
@@ -428,39 +428,22 @@ endif()
if(ENABLE_PDF_GUIDES)
# To do:
- # - Merge A4 and letter into the smallest dimension of each format.
- # Use --stringparam page.height <letter-height>mm --stringparam page.width <at-width>mm
- # Test the effect of this on letter and a4 printers first (ps and non-ps).
- # - Generate PDFs using AsciiDoc.
+ # - Generate PDFs using AsciiDoctor.
XML2PDF(
user_guide
- user-guide-a4.pdf
+ user-guide.pdf
user-guide.xml
custom_layer_pdf.xsl
- A4
)
- XML2PDF(
- user_guide
- user-guide-us.pdf
- user-guide.xml
- custom_layer_pdf.xsl
- letter
- )
add_custom_target(
- user_guide_pdf_a4
+ user_guide_pdf
DEPENDS
- user-guide-a4.pdf
+ user-guide.pdf
)
- set_target_properties(user_guide_pdf_a4 PROPERTIES FOLDER "Docbook")
- add_custom_target(
- user_guide_pdf_us
- DEPENDS
- user-guide-us.pdf
- )
- set_target_properties(user_guide_pdf_us PROPERTIES FOLDER "Docbook")
- add_dependencies(user_guides user_guide_pdf_a4 user_guide_pdf_us)
+ set_target_properties(user_guide_pdf PROPERTIES FOLDER "Docbook")
+ add_dependencies(user_guides user_guide_pdf)
endif()
if(ENABLE_CHM_GUIDES)
@@ -505,32 +488,18 @@ endif()
if(ENABLE_PDF_GUIDES)
XML2PDF(
developer_guide
- developer-guide-a4.pdf
+ developer-guide.pdf
developer-guide.xml
custom_layer_pdf.xsl
- A4
)
- XML2PDF(
- developer_guide
- developer-guide-us.pdf
- developer-guide.xml
- custom_layer_pdf.xsl
- letter
- )
add_custom_target(
- developer_guide_pdf_a4
+ developer_guide_pdf
DEPENDS
- developer-guide-a4.pdf
+ developer-guide.pdf
)
- set_target_properties(developer_guide_pdf_a4 PROPERTIES FOLDER "Docbook")
- add_custom_target(
- developer_guide_pdf_us
- DEPENDS
- developer-guide-us.pdf
- )
- set_target_properties(developer_guide_pdf_us PROPERTIES FOLDER "Docbook")
- add_dependencies(developer_guides developer_guide_pdf_a4 developer_guide_pdf_us)
+ set_target_properties(developer_guide_pdf PROPERTIES FOLDER "Docbook")
+ add_dependencies(developer_guides developer_guide_pdf)
endif()
if(ENABLE_CHM_GUIDES)
@@ -545,7 +514,7 @@ if(ENABLE_CHM_GUIDES)
add_dependencies(developer_guides developer_guide_chm)
endif()
-# release_notes: release-notes.html release-notes.txt release-notes-a4.pdf release-notes-us.pdf
+# release_notes: release-notes.html release-notes.txt
add_custom_target( release_notes_html DEPENDS ws.css release-notes.html )
set_target_properties(release_notes_html PROPERTIES FOLDER "Docbook")
@@ -583,20 +552,6 @@ if( ASCIIDOC_FOUND )
)
endif()
-#ASCIIDOC2PDF(
-# release-notes-a4.pdf
-# release-notes.asciidoc
-# "${ASCIIDOC_CONF_FILES}"
-# A4
-#)
-
-#ASCIIDOC2PDF(
-# release-notes-us.pdf
-# release-notes.asciidoc
-# "${ASCIIDOC_CONF_FILES}"
-# letter
-#)
-
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
#