aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2017-11-13 23:43:10 +0000
committerGerald Combs <gerald@wireshark.org>2017-11-14 00:46:20 +0000
commit3006ffa615d02dabe7431394b07e8b2d9888ca41 (patch)
treebde60ef906861a3c6ec803b421cf58d9a6903c0e /docbook/CMakeLists.txt
parenta595d7326b4a42f15a7b3109a6e81b4de02bbc14 (diff)
CMake,editcap: avoid noise with editcap -F and -T options
Avoid printing a noisy "option requires an argument" error when using '-T' and '-F' as documented. Fix warning that started showing on macOS with CMake 3.9.4 about CMP0058 since v2.5.0rc0-1180-g799f4f0e14. Change-Id: Ie0cc352c6b0b2724997e7fe6b49fd5b1f02d1e07 Reviewed-on: https://code.wireshark.org/review/24404 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Ahmad Fatoum <ahmad@a3f.at> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'docbook/CMakeLists.txt')
-rw-r--r--docbook/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/docbook/CMakeLists.txt b/docbook/CMakeLists.txt
index 94e9b8f206..946411cf31 100644
--- a/docbook/CMakeLists.txt
+++ b/docbook/CMakeLists.txt
@@ -81,8 +81,8 @@ foreach(th_command ${WSUG_TOOLS_HELP_COMMANDS})
list(APPEND WSUG_TOOLS_PHONY_DEPS ${th_phony})
add_custom_command(
OUTPUT ${th_phony}
- COMMAND ${CMAKE_BINARY_DIR}/run/${th_command} -h > ${th_file}
- DEPENDS ${CMAKE_BINARY_DIR}/run/${th_command}
+ COMMAND ${th_command} -h > ${th_file}
+ DEPENDS ${th_command}
)
endforeach()
@@ -95,7 +95,8 @@ list(APPEND WSUG_TOOLS_HELP_FILES ${th_file})
list(APPEND WSUG_TOOLS_PHONY_DEPS ${th_phony})
add_custom_command(
OUTPUT ${th_phony}
- COMMAND ${CMAKE_BINARY_DIR}/run/editcap -F > ${th_file}
+ COMMAND editcap -F > ${th_file}
+ DEPENDS editcap
)
set(th_file ${CMAKE_CURRENT_SOURCE_DIR}/wsug_src/editcap-T.txt)
set(th_phony editcap_T_tools_help)
@@ -103,7 +104,8 @@ list(APPEND WSUG_TOOLS_HELP_FILES ${th_file})
list(APPEND WSUG_TOOLS_PHONY_DEPS ${th_phony})
add_custom_command(
OUTPUT ${th_phony}
- COMMAND ${CMAKE_BINARY_DIR}/run/editcap -T > ${th_file}
+ COMMAND editcap -T > ${th_file}
+ DEPENDS editcap
)
add_custom_target(update_tools_help