aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2016-12-15 19:54:01 +0000
committerGraham Bloice <graham.bloice@trihedral.com>2016-12-15 20:56:21 +0000
commit8234de535022a699f6c2ac5f870cad6cd7439060 (patch)
tree78db30f06b981ec09b8244828db06f4f3f1768b3 /docbook/CMakeLists.txt
parent2c20ffa871d39457ef3e10bef3e380e1c86e9661 (diff)
Fix release-notes.html generation
The ASCIIDOC_CONF_FILES setting for asciidoc was only generated if any of the guides were being built. Clean up a dup setting and some and blank lines in FindASCIIDOC Change-Id: Ie8ab97db09e18cdb8d7e2a7bd4dcf8c288dd036f Reviewed-on: https://code.wireshark.org/review/19291 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'docbook/CMakeLists.txt')
-rw-r--r--docbook/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/docbook/CMakeLists.txt b/docbook/CMakeLists.txt
index 0ad3b33d51..29c64de8cd 100644
--- a/docbook/CMakeLists.txt
+++ b/docbook/CMakeLists.txt
@@ -305,15 +305,15 @@ ADD_CUSTOM_COMMAND(
set( WSDG_BUILT_DEPS ws.css wsluarm )
+set( ASCIIDOC_CONF_FILES
+ asciidoc.conf
+ asciidoctor-asciidoc.conf
+ attributes.asciidoc
+)
+
if(ENABLE_HTML_GUIDES OR ENABLE_PDF_GUIDES OR ENABLE_CHM_GUIDES)
# Generate the DocBook sources of user and developer guides
- set( ASCIIDOC_CONF_FILES
- asciidoc.conf
- asciidoctor-asciidoc.conf
- attributes.asciidoc
- )
-
ASCIIDOC2DOCBOOK(user-guide.asciidoc ASCIIDOC_CONF_FILES WSUG_SOURCE WSUG_BUILT_DEPS)
add_custom_target(user_guide_docbook DEPENDS generate_user-guide.xml)
set_target_properties(user_guide_docbook PROPERTIES FOLDER "Docbook")