aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-02-15 23:20:32 +0000
committerGerald Combs <gerald@wireshark.org>2008-02-15 23:20:32 +0000
commit98bacb3556206a81f78c1568f7703f28ba137f91 (patch)
tree17f802e592331df786136ba5638c6844d94dc855 /doc/Makefile.am
parent6537c76fb62d583eb5f98308c15ae31c1712a31a (diff)
Add rawshark, a utility that, when given raw pcap-formatted packets and
a list of fields, prints the field values found in each packet. Packet data can be specified as a libpcap DLT, e.g. "EN10MB" or an upper-layer protocol, e.g. "http". svn path=/trunk/; revision=24339
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 2a3502a6f2..95ae6dfd90 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -139,6 +139,18 @@ wireshark-filter.pod: wireshark-filter.pod.template ../tshark
--noindex \
$(srcdir)/dumpcap.pod > ../dumpcap.html
+../rawshark.1: rawshark.pod ../config.h
+ $(POD2MAN) \
+ --center="The Wireshark Network Analyzer" \
+ --release=$(VERSION) \
+ $(srcdir)/rawshark.pod > ../rawshark.1
+
+../rawshark.html: rawshark.pod ../config.h
+ $(POD2HTML) \
+ --title="rawshark - The Wireshark Network Analyzer $(VERSION)" \
+ --noindex \
+ $(srcdir)/rawshark.pod > ../rawshark.html
+
CLEANFILES = \
wireshark-filter.pod \
wireshark-tmp.pod \
@@ -159,7 +171,9 @@ CLEANFILES = \
../dumpcap.1 \
../dumpcap.html \
../idl2wrs.1 \
- ../idl2wrs.html
+ ../idl2wrs.html \
+ ../rawshark.1 \
+ ../rawshark.html
DISTCLEANFILES = \
pod2htmi.tmp \