aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorBalint Reczey <balint@balintreczey.hu>2021-10-20 22:52:36 +0200
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-10-21 10:42:07 +0000
commita8f1b4f12c1a0071b8a91b306ef50d12d7cc0699 (patch)
tree8941c72e731b7b01983ca3dcffb74ac5cf7f492a /debian
parent63b602973d8012f3dc8deedda77e014a0f5f1ed5 (diff)
debian/rules: Run dh_dwz with debhelper (>= 12.6) only
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index a43261cbb1..5040d087f9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -52,6 +52,10 @@ ifneq ($(filter $(DEB_BUILD_OPTIONS),nocheck),)
$(MAKE) -C $(CURDIR)/obj-* test-programs
endif
+override_dh_dwz:
+ # run dh_dwz only with debhelper (>= 12.6) to work around https://bugs.debian.org/939164
+ dpkg -l debhelper | awk '/debhelper/ {print $$3}' | xargs dpkg --compare-versions 12.6 gt || dh_dwz
+
override_dh_strip:
dh_strip --dbg-package=wireshark-dbg