aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2020-12-10 15:42:48 -0800
committerDario Lombardo <lomato@gmail.com>2020-12-29 10:09:36 +0000
commita7c6de4c660c24e12c4743f8a287bc66bcecf36c (patch)
tree5b617bbaeac291e1e1359a92a7ab08422e5c9a87 /debian
parent9783caebdfb4145ef64527513e1e12834f816277 (diff)
GitLab CI: Build merge-req:ubuntu-dpkg using Ninja.
ubuntu-dpkg is currently the slowest of the merge-req pipelines. Newer versions of dh have a "cmake+ninja" buildsystem, so try using it instead.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules17
1 files changed, 11 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 1dedf330e4..caedd97b48 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,12 +21,17 @@ export DH_OPTIONS
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- MAKE_JOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ MAKEFLAGS += -j$(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif
+
+ifeq ($(MAKE),ninja)
+ DH_BUILDSYSTEM = cmake+ninja
else
- MAKE_JOBS = 1
+ DH_BUILDSYSTEM = cmake
endif
+
%:
- dh $@ --with python3 --buildsystem cmake --with quilt --parallel
+ dh $@ --with python3 --buildsystem $(DH_BUILDSYSTEM) --with quilt --parallel
override_dh_auto_configure:
dh_auto_configure -- -DBUILD_xxx2deb=ON
@@ -34,14 +39,14 @@ override_dh_auto_configure:
override_dh_auto_build:
# Ignore warnings from asn2wrs.py about duplicate field names.
PYTHONWARNINGS='ignore:The same:UserWarning::0' \
- $(MAKE) -C $(CURDIR)/obj-* -j$(MAKE_JOBS) asn1
+ $(MAKE) -C $(CURDIR)/obj-* asn1
dh_auto_build
- $(MAKE) -C $(CURDIR)/obj-* -j$(MAKE_JOBS) user_guide_html developer_guide_html
+ $(MAKE) -C $(CURDIR)/obj-* user_guide_html developer_guide_html
# fix links in documentation
sed -i "s|$(CURDIR)/docbook|..|" obj-*/docbook/ws*g_html_chunked/*.html
ifneq ($(filter $(DEB_BUILD_OPTIONS),nocheck),)
# Required for the "unittests" suite.
- $(MAKE) -C $(CURDIR)/obj-* -j$(MAKE_JOBS) test-programs
+ $(MAKE) -C $(CURDIR)/obj-* test-programs
endif
override_dh_strip: