aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorBalint Reczey <balint.reczey@canonical.com>2019-07-15 21:01:34 +0200
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-10-10 19:26:17 +0000
commitba4bec7d0987c7e79c8deca6ad3f3fe8a1af586a (patch)
treefc40183999b6a67635e4222fda2920103bec2fd2 /debian/rules
parent6617c7fc5dd0861d92e8dc784d1f2d0ae9397257 (diff)
debian: Report upstream and package version instead of git revision
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c42457ff91..a43261cbb1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,6 +15,8 @@ ifeq ($(distrelease),n/a)
distrelease := sid
endif
+GIT_VERSION = "Git v$(DEB_VERSION_UPSTREAM)" packaged as "$(DEB_VERSION)"
+
# This has to be exported to make some magic below work.
export DH_OPTIONS
@@ -34,6 +36,7 @@ endif
dh $@ --with python3 --buildsystem $(DH_BUILDSYSTEM) --with quilt
override_dh_auto_configure:
+ echo "#define VCSVERSION \"$(GIT_VERSION)\"" > version.h
dh_auto_configure -- -DBUILD_xxx2deb=ON -DBUILD_corbaidl2wrs=ON
override_dh_auto_build: