aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2012-03-27 02:37:42 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2012-03-27 02:37:42 +0000
commitfd69e62aac818aa349ce4adab9f386f19954d6db (patch)
treea95493b54ed212d9912a97f00c9e9c5334c3c1cb /configure.in
parentce8d32d5bb14c6ada4b4f49f61aaf891bbdf9675 (diff)
Revert r37423: the intent of r34356 was to enable Airpcap by default, it just
didn't work as intended. Then make it so we build with Airpcap by default. This should hopefully be the end of https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4879 svn path=/trunk/; revision=41790
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 574e41fe8c..cb09a4dc12 100644
--- a/configure.in
+++ b/configure.in
@@ -1731,12 +1731,18 @@ AC_DEFINE(WS_VAR_IMPORT, extern, [Define as the string to precede external varia
AC_DEFINE(WS_MSVC_NORETURN,, [Define as the string to precede declarations of routines that never return])
AC_ARG_ENABLE(airpcap,
+[
AC_HELP_STRING( [--enable-airpcap],
- [use AirPcap in Wireshark @<:@default=no@:>@]),
+ [use AirPcap in Wireshark @<:@default=yes@:>@])
+],[
enable_airpcap=$enableval
if test x$enable_airpcap != xno; then
AC_DEFINE(HAVE_AIRPCAP, 1, [Enable AirPcap])
fi
+],[
+ enable_airpcap=yes
+ AC_DEFINE(HAVE_AIRPCAP, 1, [Enable AirPcap])
+]
)
dnl Checks for typedefs, structures, and compiler characteristics.