aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSebastien Tandel <sebastien@tandel.be>2007-06-18 02:23:44 +0000
committerSebastien Tandel <sebastien@tandel.be>2007-06-18 02:23:44 +0000
commitd3b8c062ea7360780c828f36066602d0013a9262 (patch)
tree75a65c85bbfb63dd189920061bc654dbfcfec4a3 /configure.in
parentc38ff4359146578f74a07d51e1d8010ecd5dbaeb (diff)
get rid of the "case" statement to test the value of withval.
svn path=/trunk/; revision=22126
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 7 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index e303e3ed24..a5999b7f3d 100644
--- a/configure.in
+++ b/configure.in
@@ -1416,27 +1416,16 @@ AC_ARG_WITH(plugins,
AC_HELP_STRING( [--with-plugins@<:@=DIR@:>@],
[support plugins (installed in DIR, if supplied). @<:@default=yes, if possible@:>@]),
[
- case "$withval" in
- "" | y | ye | yes )
- if test x$have_plugins = xno
- then
- AC_MSG_ERROR([GLib on this platform doesn't support loadable modules, so you can't enable plugins.])
- fi
- ;;
- n | no)
+ if test "x$withval" = "xno"; then
have_plugins=no
- ;;
- *)
- if test x$have_plugins = xno
- then
+ elif test "x$have_plugins" = "xno"; then
AC_MSG_ERROR([GLib on this platform doesn't support loadable modules, so you can't enable plugins.])
- fi
- plugindir="$withval"
- ;;
- esac
+ if test "x$withval" != "xyes"; then
+ plugindir="$withval"
+ fi
+ fi
])
-
-AM_CONDITIONAL(HAVE_PLUGINS, test x$have_plugins = xyes)
+AM_CONDITIONAL(HAVE_PLUGINS, test "x$have_plugins" = "xyes")
if test x$have_plugins = xyes
then
AC_DEFINE(HAVE_PLUGINS, 1, [Define if plugins are enabled])