aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2012-01-17 05:22:56 +0000
committerGuy Harris <guy@alum.mit.edu>2012-01-17 05:22:56 +0000
commitd39be3c7c4c8ce0582c32cdd10e04266664676d5 (patch)
treeba9ed49751a8d7875a68af8601a854273d2bd481 /configure.in
parent7da19cf33286de355fca97027b36d582d1986cbc (diff)
Indicate which version of GTK+ is being used to build Wireshark, and
also indicate if we're including the Mac OS X integration library. svn path=/trunk/; revision=40556
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f013430613..7484e81e85 100644
--- a/configure.in
+++ b/configure.in
@@ -2020,13 +2020,25 @@ dnl AC_CONFIG_FILES([tools/setuid-root.pl], [chmod +x tools/setuid-root.pl])
# Pretty messages
+if test "x$have_gtk" = "xyes"; then
+ if test "x$with_gtk3" = "xyes"; then
+ gui_lib_message=" (with GTK+ 3"
+ else
+ gui_lib_message=" (with GTK+ 2"
+ fi
+ if test "x$have_ige_mac" = "xyes"; then
+ gui_lib_message="$gui_lib_message and Mac OS X integration)"
+ else
+ gui_lib_message="$gui_lib_message)"
+ fi
+fi
+
if test "x$enable_setcap_install" = "xyes" ; then
setcap_message="yes"
else
setcap_message="no"
fi
-
if test "x$enable_setuid_install" = "xyes" ; then
setuid_message="yes"
else
@@ -2105,7 +2117,7 @@ fi
echo ""
echo "The Wireshark package has been configured with the following options."
-echo " Build wireshark : $enable_wireshark"
+echo " Build wireshark : $enable_wireshark""$gui_lib_message"
echo " Build tshark : $enable_tshark"
echo " Build capinfos : $enable_capinfos"
echo " Build editcap : $enable_editcap"