aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>1998-10-28 21:52:48 +0000
committerGerald Combs <gerald@wireshark.org>1998-10-28 21:52:48 +0000
commita0fbb64bf9fffcabd5e716e65e63774081cd4c91 (patch)
tree011724061fb4ba41fb3f670fbd978fae1ab2f96e /configure.in
parent06e5aae0e3946b453377f7d824ef43961dfa47aa (diff)
* Changes to make things easier on people with misplaced or missing pcap
headers. svn path=/trunk/; revision=76
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 19 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8d06541e1d..75056d6ef1 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.8 1998/10/13 02:10:52 gerald Exp $
+# $Id: configure.in,v 1.9 1998/10/28 21:52:48 gerald Exp $
dnl Process this file with autoconf to produce a configure script.
AC_INIT(etypes.h)
@@ -39,10 +39,27 @@ AM_PATH_GTK(1.0.0, CFLAGS="$CFLAGS $GTK_CFLAGS" LIBS="$LIBS $GTK_LIBS",
AC_MSG_ERROR(GTK+ distribution not found.))
# Pcap checks
-AC_CHECK_HEADER(pcap.h,, AC_MSG_ERROR(Header file pcap.h not found.))
AC_CHECK_HEADER(net/bpf.h,, AC_MSG_ERROR(Header file net/bpf.h not found.))
+AC_CHECK_HEADER(pcap.h,, AC_MSG_ERROR(Header file pcap.h not found.))
AC_CHECK_LIB(pcap, pcap_open_offline,, AC_MSG_ERROR(Library libpcap not found.))
+# Evidently, some systems have pcap.h, etc. in */include/pcap
+AC_MSG_CHECKING(for extraneous pcap header directories)
+found_pcap_dir=""
+for pcap_dir in /usr/include/pcap /usr/local/include/pcap
+do
+ if test -d $pcap_dir ; then
+ LIBS="$LIBS -L$pcap_dir"
+ found_pcap_dir=" $found_pcap_dir -L$pcap_dir"
+ fi
+done
+
+if test "$found_pcap_dir" != "" ; then
+ AC_MSG_RESULT(found --$found_pcap_dir added to LIBS)
+else
+ AC_MSG_RESULT(not found)
+fi
+
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(fcntl.h strings.h sys/ioctl.h sys/time.h unistd.h stdarg.h)