aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2007-04-14 00:35:53 +0000
committerJörg Mayer <jmayer@loplof.de>2007-04-14 00:35:53 +0000
commit6c8b972c62d20556d68e3cec19f282e6808af388 (patch)
treed171627cec7ff3ec0263516d44b3ab401d65c29e /configure.in
parent2878fd21d65dd0f1d5b1f89f86647b3c7f81edbf (diff)
Disable warnings as errors if extra gcc warnings was specified.
Change to positive logic --without-warnings-as-errors (default no) ==> --with-warnings-as-errors (default yes) svn path=/trunk/; revision=21425
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 16 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 88194b978c..fcf9df0827 100644
--- a/configure.in
+++ b/configure.in
@@ -209,20 +209,28 @@ else
fi
rm -rf conftest*
+AC_MSG_CHECKING(whether we should treat compiler warnings as errors)
AC_ARG_WITH(warnings-as-errors,
- AC_HELP_STRING( [--without-warnings-as-errors],
- [Don't treat warnings as errors (only for gcc). [default=yes]]),
+ AC_HELP_STRING( [--with-warnings-as-errors],
+ [Treat warnings as errors (only for gcc). [default=yes]]),
[
- without_warnings_as_errors="no"
- if test "x$GCC" != "x" && test "x$withval" = "xno"; then
- without_warnings_as_errors="yes"
+ if test "x$GCC" != "x" && test "x$withval" != "xno"; then
+ with_warnings_as_errors="no"
+ AC_MSG_RESULT(no)
+ else
+ with_warnings_as_errors="yes"
+ AC_MSG_RESULT(yes)
fi
],
- if test "x$GCC" != "x"; then
- without_warnings_as_errors="no"
+ if test "x$GCC" != "x" && test "x$wireshark_extra_gcc_flags" = "x"; then
+ with_warnings_as_errors="yes"
+ AC_MSG_RESULT(yes)
+ else
+ with_warnings_as_errors="no"
+ AC_MSG_RESULT(no)
fi
)
-AM_CONDITIONAL(HAVE_WARNINGS_AS_ERRORS, test "x$without_warnings_as_errors" = "xno")
+AM_CONDITIONAL(HAVE_WARNINGS_AS_ERRORS, test "x$with_warnings_as_errors" = "xyes")
#
# Add any platform-specific compiler flags needed.