aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2005-02-20 05:01:46 +0000
committerJörg Mayer <jmayer@loplof.de>2005-02-20 05:01:46 +0000
commit6b650bc433700a63a3e91586a6ac0d6260f727c1 (patch)
tree7f569b5795c6355fe25d87a8400b375edffcccb3 /configure.in
parent794eb11464670801e1f395c47ce7651add7e2c76 (diff)
Beginnings of autogenerating docbook/Makefile (long way to go) so call it Makefile.auto for now
svn path=/trunk/; revision=13439
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 150cb130fb..f3c07ed009 100644
--- a/configure.in
+++ b/configure.in
@@ -47,12 +47,34 @@ AC_SUBST(POD2HTML)
AC_SUBST(LEX)
AC_SUBST(FLEX_PATH)
AC_SUBST(PYTHON)
+AC_SUBST(XSLTPROC)
+AC_SUBST(XMLLINT)
# Check for doxygen
AC_PATH_PROG(DOXYGEN, doxygen)
AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, "yes", "no")
AM_CONDITIONAL(HAVE_DOXYGEN, test x$HAVE_DOXYGEN = xyes)
+# Check for xsltproc
+AC_PATH_PROG(XSLTPROC, xsltproc)
+AC_CHECK_PROG(HAVE_XSLTPROC, xsltproc, "yes", "no")
+AM_CONDITIONAL(HAVE_XSLTPROC, test x$HAVE_XSLTPROC = xyes)
+
+# Check for xmllint
+AC_PATH_PROG(XMLLINT, xmllint)
+AC_CHECK_PROG(HAVE_XMLLINT, xmllint, "yes", "no")
+AM_CONDITIONAL(HAVE_XMLLINT, test x$HAVE_XMLLINT = xyes)
+
+# Check for fop (
+AC_PATH_PROG(FOP, fop.sh)
+AC_CHECK_PROG(HAVE_FOP, fop.sh, "yes", "no")
+AM_CONDITIONAL(HAVE_FOP, test x$HAVE_FOP = xyes)
+
+# Check for hhc (html help compiler)
+AC_PATH_PROG(HHC, hhc.exe)
+AC_CHECK_PROG(HAVE_HHC, hhc.exe, "yes", "no")
+AM_CONDITIONAL(HAVE_HHC, test x$HAVE_HHC = xyes)
+
# Check for packaging utilities
# For now, we check to see if the various packaging utilites are in our
# path. I'm too lazy to write code to go hunt for them. - Gerald
@@ -1211,6 +1233,7 @@ AC_OUTPUT(
Makefile
doxygen.cfg
doc/Makefile
+ docbook/Makefile.auto
epan/Makefile
epan/doxygen.cfg
epan/dfilter/Makefile