aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorStephen Fisher <steve@stephen-fisher.com>2007-03-23 17:49:59 +0000
committerStephen Fisher <steve@stephen-fisher.com>2007-03-23 17:49:59 +0000
commit62f88a4a04d8e300ff108f6164e9016e8cdcc9c3 (patch)
tree73b10da0cb64b46cc16c63fa8ee0c6289727dd33 /configure.in
parent1f9eafa4fb5d351abb79034d9000d853d89f47fe (diff)
From Sebastien Tandel:
(Temporarily disable the warnings as errors default on Unix to get to get the buildbots and people with gcc40 going again until those additional warnings gcc40 generates can be fixed-I'm working on it ASAP) Patch for configure.in which disables by default the treatment of warnings as errors. It can be enabled with './configure --with-warnings-as-errors'. The macro will test first if GCC is present. If it's the case, HAVE_WARNINGS_AS_ERRORS is defined. All the USING_GCC have been replaced by HAVE_WARNINGS_AS_ERRORS. With this switch, people won't suffer from unexpected warnings when downloading svn sources during the transition time ;) svn path=/trunk/; revision=21153
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e9602ad593..5dd3a58179 100644
--- a/configure.in
+++ b/configure.in
@@ -174,8 +174,18 @@ else
AC_MSG_RESULT(no)
fi
-# Create the USING_GCC variable for use in Makefile.am files
-AM_CONDITIONAL(USING_GCC, test "x$GCC" != "x")
+AC_ARG_WITH(warnings-as-errors,
+[ --with-warnings-as-errors Treat warnings as errors (if using gcc). [default=no]],
+[
+ if test "x$GCC" != "x"; then
+ if test "x$withval" != "xno"; then
+ with_warnings_as_errors="yes"
+ fi
+ else
+ with_warnings_as_errors="no"
+ fi
+],)
+AM_CONDITIONAL(HAVE_WARNINGS_AS_ERRORS, test "x$with_warnings_as_errors" = "xyes")
#
# Add any platform-specific compiler flags needed.