aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2003-11-18 08:13:10 +0000
committerGuy Harris <guy@alum.mit.edu>2003-11-18 08:13:10 +0000
commit240c946b8247437817e6947a089f32fdf2e4d06a (patch)
treef79fc2d98f381d8f215a90b2cc836c8d863f8afa /configure.in
parent58674394989198accbcfe7dcfbe5f92888bed25d (diff)
From Olivier Biot: add a "--enable-profile-build" flag to request that
"-pg" binaries be built. svn path=/trunk/; revision=9001
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 35bb8c2696..31e7b15f5a 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.232 2003/11/17 22:09:16 guy Exp $
+# $Id: configure.in,v 1.233 2003/11/18 08:13:05 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -236,6 +236,22 @@ AC_ARG_ENABLE(threads,
[ --enable-threads use threads in ethereal. [default=no]],enable_threads=$enableval,enable_threads=no)
AM_CONDITIONAL(USE_THREADS, test x$enable_threads = xyes)
+AC_ARG_ENABLE(profile-build,
+[ --enable-profile-build build profile-ready binaries. [default=no]],enable_profile_build=$enableval,enable_profile_build=no)
+AM_CONDITIONAL(USE_PROFILE_BUILD, test x$enable_profile_build = xyes)
+AC_MSG_CHECKING(if profile builds must be generated)
+if test "x$enable_profile_build" = "xyes" ; then
+ if test -n "$GCC" ; then
+ AC_MSG_RESULT(yes)
+ CFLAGS=" -pg $CFLAGS"
+ else
+ AC_MSG_RESULT(no)
+ echo "Building profile binaries currently only supported for GCC."
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
+
# GTK checks
# We don't add $GLIB_LIBS to LIBS, because we don't want to force all
# programs to be built with GTK+.
@@ -874,6 +890,7 @@ echo " Use plugins : $have_plugins"
echo " Use GTK+ v2 library : $enable_gtk2"
if test "x$enable_gtk2" = "xyes" ; then
echo " Use threads : $enable_threads"
+echo " Build profile binaries : $enable_profile_build"
fi
echo " Use pcap library : $want_pcap"
echo " Use zlib library : $zlib_message"