aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2012-01-20 03:20:35 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2012-01-20 03:20:35 +0000
commit0a6eca4097b839b3c02fe1d18da04f33fb935bdd (patch)
treeb39a0a303af21785b72d170b6727209797380865 /configure.in
parentb83e1b218f5e0b110a2d5a942a6f564bbb099351 (diff)
Bug 6448 says the embedded Python stuff does not really work.
And if I run Valgrind with Python enabled, I get pages of errors related to it. So: disable Python by default. svn path=/trunk/; revision=40602
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 7484e81e85..73ebc2aac1 100644
--- a/configure.in
+++ b/configure.in
@@ -1620,7 +1620,7 @@ AC_MSG_CHECKING(whether to use the Python interpreter for scripting)
AC_ARG_WITH(python,
AC_HELP_STRING( [--with-python@<:@=DIR@:>@],
- [use Python interpreter (installed in DIR, if supplied) @<:@default=yes, if available@:>@ (EXPERIMENTAL)]),
+ [use Python interpreter (installed in DIR, if supplied) @<:@default=no@:>@ (EXPERIMENTAL)]),
[
pythondir='${libdir}/wireshark/python/${VERSION}'
if test "x$withval" = "xno"
@@ -1634,12 +1634,11 @@ AC_ARG_WITH(python,
pythondir="$withval"
fi
],[
+ # By default (user didn't explicitly enable Python), don't enable
+ # Python support.
#
- # Use the embeddable Python interpreter if it's present,
- # otherwise don't.
- #
- want_pythin=ifavailable
- pythondir='${libdir}/wireshark/python/${VERSION}'
+ want_python=no
+ #pythondir='${libdir}/wireshark/python/${VERSION}'
])
if test "x$want_python" = "xno" ; then
AC_MSG_RESULT(no)