aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2006-12-08 15:05:41 +0000
committerJörg Mayer <jmayer@loplof.de>2006-12-08 15:05:41 +0000
commite26860607db1b260da079f5a52f21b2e19b60f03 (patch)
treee965cd244a9542db485d393045c2e41ba44090ea /configure.in
parent6404c0662002d345f8708640ab66397bea948c48 (diff)
Get rid of UCD SNMP support (it's not longer supported and
superseeded by net-snmp). Replace some_snmp by net_snmp where appropriate. svn path=/trunk/; revision=20071
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in51
1 files changed, 5 insertions, 46 deletions
diff --git a/configure.in b/configure.in
index 7b962165f1..c75e61be29 100644
--- a/configure.in
+++ b/configure.in
@@ -940,7 +940,7 @@ else
fi
AC_SUBST(SSL_LIBS)
-dnl UCD SNMP/Net-SNMP Check
+dnl Net-SNMP Check
SNMP_LIBS=''
AC_ARG_WITH(net-snmp,
@@ -964,30 +964,8 @@ AC_ARG_WITH(net-snmp,
want_netsnmp=ifavailable
])
-AC_ARG_WITH(ucd-snmp,
-[ --with-ucd-snmp[[=DIR]] use UCD SNMP client library (located in directory DIR, if supplied). [[default=yes, if available]]],
-[
- if test $withval = no
- then
- want_ucdsnmp=no
- elif test $withval = yes
- then
- want_ucdsnmp=yes
- else
- want_ucdsnmp=yes
- ucdsnmp_dir=$withval
- fi
-],[
- #
- # Set "want_ucdsnmp" to "ifavailable" to make the default "use it
- # if you find it, otherwise don't".
- #
- want_ucdsnmp=ifavailable
- ucdsnmp_dir=
-])
-
#
-# Try Net-SNMP first.
+# Try Net-SNMP
#
AC_MSG_CHECKING(whether to use Net-SNMP library)
if test "x$want_netsnmp" = "xno" ; then
@@ -1001,25 +979,8 @@ else
AC_WIRESHARK_NETSNMP_CHECK
fi
-#
-# If that didn't find Net-SNMP, try UCD SNMP.
-#
-if test "x$have_net_snmp" != "xyes" ; then
- AC_MSG_CHECKING(whether to use UCD SNMP library)
- if test "x$want_ucdsnmp" = "xno" ; then
- AC_MSG_RESULT(no)
- else
- if test "x$want_ucdsnmp" = "xifavailable" ; then
- AC_MSG_RESULT([yes, if available])
- else
- AC_MSG_RESULT(yes)
- fi
- AC_WIRESHARK_UCDSNMP_CHECK
- fi
-fi
-
-if test "x$have_net_snmp" = "xyes" || test "x$have_ucd_snmp" = "xyes"; then
- AC_DEFINE(HAVE_SOME_SNMP, 1, [Define to 1 if some SNMP support is to be used])
+if test "x$have_net_snmp" = "xyes"; then
+ AC_DEFINE(HAVE_NET_SNMP, 1, [Define to 1 if Net-SNMP support is to be used])
fi
AC_SUBST(SNMP_LIBS)
@@ -1453,9 +1414,7 @@ else
fi
if test "x$have_net_snmp" = "xyes" ; then
- snmp_libs_message="yes (net-snmp)"
-elif test "x$have_ucdsnmp" = "xyes" ; then
- snmp_libs_message="yes (ucd-snmp)"
+ snmp_libs_message="yes"
else
snmp_libs_message="no"
fi