aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2007-04-22 23:01:49 +0000
committerJörg Mayer <jmayer@loplof.de>2007-04-22 23:01:49 +0000
commit8ff9801ec152d3a34df0111ace12c9eb6fd1c689 (patch)
treeae5b3a316a20baec6dfc024678c541682aee4cd4 /configure.in
parentcb92dd701915c46ddb078c39f565efb55cdd8990 (diff)
Fix regression: Automatically disable -Werror in case of extra gcc flags.
svn path=/trunk/; revision=21513
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 71f65cfa9f..1f49064ee0 100644
--- a/configure.in
+++ b/configure.in
@@ -154,6 +154,7 @@ AC_ARG_ENABLE(extra-gcc-checks,
AC_HELP_STRING( [--enable-extra-gcc-checks],
[Do additional -W checks in GCC. @<:@default=no@:>@]),
[
+ wireshark_extra_gcc_flags=$enableval
if test $enableval != no
then
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wcast-qual)
@@ -192,7 +193,7 @@ AC_ARG_ENABLE(warnings-as-errors,
AC_HELP_STRING( [--enable-warnings-as-errors],
[Treat warnings as errors (only for gcc). @<:@default=yes@:>@]),
[
- if test "x$GCC" = "xyes" && test "x$enableval" == "xyes"; then
+ if test "x$GCC" = "xyes" -a "x$enableval" == "xyes" -a "x$wireshark_extra_gcc_flags" != "xyes"; then
with_warnings_as_errors="yes"
AC_MSG_RESULT(yes)
else
@@ -200,7 +201,7 @@ AC_ARG_ENABLE(warnings-as-errors,
AC_MSG_RESULT(no)
fi
],
- if test "x$GCC" = "xyes" && test "x$wireshark_extra_gcc_flags" = "x"; then
+ if test "x$GCC" = "xyes" -a "x$wireshark_extra_gcc_flags" = "x"; then
with_warnings_as_errors="yes"
AC_MSG_RESULT(yes)
else