aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorStephen Fisher <steve@stephen-fisher.com>2007-03-28 21:55:11 +0000
committerStephen Fisher <steve@stephen-fisher.com>2007-03-28 21:55:11 +0000
commit8fd3ee05600dd7d0e6434e7eb824932c52000ce3 (patch)
treedc1df6288600e883ed53ac7e43a38a2d03abb9f3 /configure.in
parent32780e71e8ce8c8fd1898cbcb62f6bc8a59341f3 (diff)
Remove almost all of the casts I committed recently and in place of
them, add -Wno-pointer-sign to CFLAGS when gcc will accept it. svn path=/trunk/; revision=21253
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 70f07c33bc..1aeba1bb27 100644
--- a/configure.in
+++ b/configure.in
@@ -191,6 +191,23 @@ else
fi
rm -rf conftest*
+AC_MSG_CHECKING(to see if we can add '-Wno-pointer-sign' to CFLAGS)
+if test x$GCC == xyes ; then
+ # some versions of GCC support this directive
+ rm -rf conftest*
+ echo "int foo;" >>conftest.c
+ if $CC -c -o conftest.o conftest.c -Wno-pointer-sign > /dev/null 2>&1 ; then
+ CFLAGS="$CFLAGS -Wno-pointer-sign"
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
+else
+ # non-gcc compilers do not support this directive
+ AC_MSG_RESULT(no)
+fi
+rm -rf conftest*
+
AC_ARG_WITH(warnings-as-errors,
[ --with-warnings-as-errors Treat warnings as errors (if using gcc). [default=no]],
[