aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2010-05-25 00:35:44 +0000
committerGuy Harris <guy@alum.mit.edu>2010-05-25 00:35:44 +0000
commit36623bcb712ad6553c7c33ff92d69130e62aec1d (patch)
tree23818f5c9d00bffc5d4317f7f0d5fd36508dd58d /configure.in
parent9bafe2064358245a0d85d3e1a3da0ec0cbe31598 (diff)
From H.sivank: GtkOSXApplication support.
Call the various flavors of OS X integration just "OS X integration", not anything with "IGE" in it - it appears that, in some places, "ige-mac-integration" refers only to the older Carbon-based functions, although the library still appears to be called -ligemacintegration. Update the URLs for the information about the OS X integration libraries. Clean up help message for --with-pcap-remote. Clean up white space a bit. Speaking of white space, it's "Mac OS X", not "MacOS X". svn path=/trunk/; revision=32941
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in53
1 files changed, 30 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index 109965f99f..e81ffa3cef 100644
--- a/configure.in
+++ b/configure.in
@@ -800,30 +800,36 @@ main(void)
AC_MSG_RESULT($ac_cv_dladdr_finds_executable_path)
fi
-dnl IGE Mac integration check
-AC_MSG_CHECKING(whether to use IGE Mac integration functions)
-
-AC_ARG_WITH(ige-mac-integration,
- AC_HELP_STRING( [--with-ige-mac-integration],
- [use IGE Mac integration. (@<:@default=yes, if available@:>@]),
-[
- if test $withval = no
- then
- want_ige_mac_integration=no
+if test "x$no_gtk" != "xyes"
+then
+ #
+ # We have GTK+; do we want the OS X integration functions and,
+ # if so, do we have them and, if so, which versions do we have,
+ # the old Carbon-based ones or the new Cocoa-based ones?
+ #
+ AC_MSG_CHECKING(whether to use OS X integration functions)
+
+ AC_ARG_WITH(osx-integration,
+ AC_HELP_STRING( [--with-osx-integration],
+ [use OS X integration functions (@<:@default=yes, if available@:>@]),
+ [
+ if test $withval = no
+ then
+ want_osx_integration=no
+ else
+ want_osx_integration=yes
+ fi
+ ],[
+ want_osx_integration=yes
+ ])
+ if test "x$want_osx_integration" = "xno"; then
+ AC_MSG_RESULT(no)
else
- want_ige_mac_integration=yes
+ AC_MSG_RESULT(yes)
+ AC_WIRESHARK_OSX_INTEGRATION_CHECK
fi
-],[
- want_ige_mac_integration=yes
-])
-if test "x$want_ige_mac_integration" = "xno" -o "x$no_gtk" = "xyes" ; then
- AC_MSG_RESULT(no)
-else
- AC_MSG_RESULT(yes)
- AC_WIRESHARK_IGE_MAC_INTEGRATION_CHECK
fi
-
AC_SUBST(wireshark_bin)
AC_SUBST(wireshark_man)
@@ -1074,7 +1080,8 @@ dnl pcap remote check
AC_MSG_CHECKING(whether to use libpcap remote capturing feature)
AC_ARG_WITH(pcap-remote,
-[ --with-pcap-remote use libpcap remote capturing (requires libpcap)],
+ AC_HELP_STRING([--with-pcap-remote],
+ [use libpcap remote capturing (requires libpcap)]),
[
if test $withval = no
then
@@ -1096,8 +1103,8 @@ dnl zlib check
AC_MSG_CHECKING(whether to use zlib for reading compressed capture files)
AC_ARG_WITH(zlib,
- AC_HELP_STRING( [--with-zlib@<:@=DIR@:>@],
- [use zlib (located in directory DIR, if supplied) to read compressed data. @<:@default=yes, if available@:>@]),
+ AC_HELP_STRING([--with-zlib@<:@=DIR@:>@],
+ [use zlib (located in directory DIR, if supplied) to read compressed data. @<:@default=yes, if available@:>@]),
[
if test $withval = no
then