aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2010-09-17 07:24:35 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2010-09-17 07:24:35 +0000
commitd0864ca974b8a660adc79588b77f3805f26fe9bf (patch)
tree7dc47ad5fd2af633d4a8db6eb66028df8fa201c2 /configure.in
parent8ccfaca257c3d22b2cd0459349ddc17cb9d6f704 (diff)
Put the definition of NEW_PACKET_LIST into config.h rather than the
Makefile; that will force a rebuild if you configure it on or off (that'll rebuild stuff that doesn't need to be rebuilt, but it'll also rebuild stuff that *does* need to be rebuilt and that wouldn't be rebuilt otherwise). git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@34145 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e00431334e..0cdcf9b014 100644
--- a/configure.in
+++ b/configure.in
@@ -1747,7 +1747,8 @@ AC_ARG_ENABLE(new-packet-list,
AC_MSG_CHECKING(if new packet list is used);
if test "x$new_packet_list" = "xyes" ; then
AC_MSG_RESULT(yes)
- CFLAGS=" -DNEW_PACKET_LIST $CFLAGS"
+ AC_DEFINE(NEW_PACKET_LIST, 1,
+ [Use the new packet list code])
else
AC_MSG_RESULT(no)
fi