aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorstig <stig@f5534014-38df-0310-8fa8-9805f1628bb7>2011-07-29 19:35:16 +0000
committerstig <stig@f5534014-38df-0310-8fa8-9805f1628bb7>2011-07-29 19:35:16 +0000
commit8edf14bda90978cef12f061f979f85eb836647dc (patch)
tree56a069392995d2b58119f02390211a7a521646fd /configure.in
parentc1172b2a73cdd1a0eefd170270c7703218c82ebb (diff)
Print a more correct error message when missing gtk3.
This fixes bug 6181. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@38262 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 11f33a5998..bc921bc565 100644
--- a/configure.in
+++ b/configure.in
@@ -851,7 +851,11 @@ if test "$GTK_OK" = "no" ; then
# Wireshark unless they fix the GTK+ problem).
#
if test "x$enable_wireshark" = "xyes"; then
- AC_MSG_ERROR([GTK+ 2.12 or later isn't available, so Wireshark can't be compiled])
+ if test "x$with_gtk3" = "xyes"; then
+ AC_MSG_ERROR([GTK+ 3.0 or later isn't available, so Wireshark can't be compiled])
+ else
+ AC_MSG_ERROR([GTK+ 2.12 or later isn't available, so Wireshark can't be compiled])
+ fi
fi
wireshark_bin=""
wireshark_man=""