aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2002-01-30 23:01:33 +0000
committerGuy Harris <guy@alum.mit.edu>2002-01-30 23:01:33 +0000
commit595513d5cc8f3f67d7b944e922826d3237ee4968 (patch)
tree7bc71f3dadaa8bb458503900d00244b8e026ea30 /configure.in
parent7f2e644e84d70bc1e9f737cd1d24dd1ed5904373 (diff)
Add a "--without-gcc" option, similar to what tcpdump and libpcap have.
(This isn't as useful for testing purposes as it is in tcpdump and libpcap, as GLib is configured based on the compiler used to compile it, so you can't necessarily build an application using GLib with a compiler different from the one used to compile GLib, but we'll add it anyway.) svn path=/trunk/; revision=4637
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5100dfe5a5..3a298380b1 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.148 2002/01/30 10:05:07 guy Exp $
+# $Id: configure.in,v 1.149 2002/01/30 23:01:30 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -19,6 +19,11 @@ dnl Check for CPU / vendor / OS
AC_CANONICAL_HOST
dnl Checks for programs.
+AC_ARG_WITH(gcc, [ --without-gcc don't use gcc])
+if test -z "$CC" -a "$with_gcc" = no ; then
+ CC=cc
+ export CC
+fi
AC_PROG_CC
AC_PROG_CPP
AC_PROG_RANLIB