aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2001-06-02 06:21:14 +0000
committerGuy Harris <guy@alum.mit.edu>2001-06-02 06:21:14 +0000
commit14ab278788649dda5708e23c012b27f79f58333a (patch)
treed0c705c84de2ea66679b6ae6286d74fe3060a46d /configure.in
parent89a74629b27c4a462cabac80a3170fec156ad1b8 (diff)
Windows and the MSVC++ 6.0 library don't have "strptime()", so pull in
the glibc "strptime()" (modified so it doesn't require the rest of glibc), set up the configure script to check for it, and set up Makefile.am and Makefile.nmake to use it. Get rid of NEED_MKSTEMP - nothing uses it. svn path=/trunk/; revision=3500
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index efbe05c18e..d6850cfb7c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.127 2001/05/24 04:04:42 guy Exp $
+# $Id: configure.in,v 1.128 2001/06/02 06:21:13 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -533,11 +533,19 @@ AC_CHECK_FUNC(mkstemp, MKSTEMP_O="",
if test "$ac_cv_func_mkstemp" = no ; then
MKSTEMP_C="mkstemp.c"
MKSTEMP_O="mkstemp.o"
- AC_DEFINE(NEED_MKSTEMP)
fi
AC_SUBST(MKSTEMP_C)
AC_SUBST(MKSTEMP_O)
+AC_CHECK_FUNC(strptime, STRPTIME_O="",
+ STRPTIME_O="strptime.o" [AC_DEFINE(NEED_STRPTIME_H)])
+if test "$ac_cv_func_strptime" = no ; then
+ STRPTIME_C="strptime.c"
+ STRPTIME_O="strptime.o"
+fi
+AC_SUBST(STRPTIME_C)
+AC_SUBST(STRPTIME_O)
+
AC_CHECK_FUNCS(getprotobynumber gethostbyname2)
dnl blank for now, but will be used in future